mongoDB v2.4.5 & rabbitMQ v3.1.3

Quick catch-up on recent bumps I’ve made for rabbitMQ and mongoDB before posting about EuroPython2013 !

mongoDB v2.4.5

The 2.4 branch is definitely the most bugged one I’ve seen so far. We waited until 2.4.4 at work before migrating but this was not enough and we got hit for a few weeks by a bug which finally got fixed in 2.4.5. Also this release fixes two security bugs so you’re strongly advised to upgrade.

highlights

  • CVE-2013-4650 – Improperly grant user system privileges on databases other than “local”.
  • CVE-2013-4650 – Remotely triggered segmentation fault in Javascript engine.
  • config server performance improvements
  • improve initial sync resilience to network failure (that’s the one)

flask-pymongo v0.3.0

@dcrosta finally had the time to take care of my pull request for flask-pymongo. We now rely on pymongo’s MongoClient parameters’ validation instead of implementing them again on flask-pymongo and added connect and socket timeout options.

rabbitMQ v3.1.3

A roll-up bugfix release mainly.

highlights

  • fix startup failure when using SSL with Erlang/OTP R16B01
  • fix queue crash requeuing in-memory messages (since 2.7.0)
  • fix leak affecting HA/mirrored queues (since 3.0.0)
  • fix bug that lead to incorrect reporting of accumulated stats (since 3.1.2)

 

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>